home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-fs / xfsprogs-2.6.25 / xfsprogs-2.6.25.ebuild < prev   
Text File  |  2005-10-18  |  2KB  |  69 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.25.ebuild,v 1.15 2005/06/02 01:42:03 vapier Exp $
  4.  
  5. inherit flag-o-matic eutils
  6.  
  7. DESCRIPTION="xfs filesystem utilities"
  8. HOMEPAGE="http://oss.sgi.com/projects/xfs/"
  9. SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
  10.  
  11. LICENSE="LGPL-2.1"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 ~sparc x86"
  14. IUSE="nls"
  15.  
  16. RDEPEND="sys-fs/e2fsprogs"
  17. DEPEND="${RDEPEND}
  18.     nls? ( sys-devel/gettext )"
  19.  
  20. src_unpack() {
  21.     unpack ${A}
  22.     cd "${S}"
  23.  
  24.     epatch "${FILESDIR}"/${P}-gcc4.patch
  25.  
  26.     # temp work around till a _syscall6() exists. bug #73855
  27.     use elibc_uclibc && epatch "${FILESDIR}"/2.6.25-uclibc-fadvise.patch
  28.  
  29.     # Inject our own CFLAGS / docpath
  30.     sed -i \
  31.         -e '/^GCFLAGS/s:-O1::' \
  32.         -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
  33.         include/builddefs.in \
  34.         || die "sed include/builddefs.in failed"
  35.     # make sure the PLATFORM envvar doesn't break crap
  36.     sed -i -e '/PLATFORM/d' configure || die "sed PLATFORM"
  37.     # We'll handle /lib versus /usr/lib install
  38.     sed -i -e '/INSTALL.* -S .*LIBNAME/d' \
  39.         include/buildmacros || die "sed symlinks"
  40. }
  41.  
  42. src_compile() {
  43.     replace-flags -O[2-9] -O1
  44.     export OPTIMIZER="${CFLAGS}"
  45.     export DEBUG=-DNDEBUG
  46.  
  47.     econf \
  48.         --bindir=/bin \
  49.         --sbindir=/sbin \
  50.         --libexecdir=/usr/$(get_libdir) \
  51.         $(use_enable nls gettext) \
  52.         || die "config failed"
  53.     emake || die
  54. }
  55.  
  56. src_install() {
  57.     make DIST_ROOT="${D}" \
  58.         install install-dev \
  59.         || die "make install failed"
  60.  
  61.     # shared in /lib, static in /usr/lib, ldscript fun too
  62.     dodir /$(get_libdir)
  63.     mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/
  64.     dosym libhandle.so.1 /$(get_libdir)/libhandle.so
  65.     gen_usr_ldscript libhandle.so
  66.  
  67.     prepalldocs
  68. }
  69.